Wave - Switch to this plan

Solved Posted In Wave
  • nick-jensen 11 months ago
    I am experiencing an issue with the Plan Upgrade.
    
    When you click the "Switch To This Plan" button, it seems to be reloading the page and not actively sending the POST request to the `/plans/update` route.
    
    I belive it is reloading before setting the hidden input.
    
    Anyone else with this issue?

    I am experiencing an issue with the Plan Upgrade.

    When you click the "Switch To This Plan" button, it seems to be reloading the page and not actively sending the POST request to the /plans/update route.

    I belive it is reloading before setting the hidden input.

    Anyone else with this issue?

  • Best Answer

    (As selected by nick-jensen)

    nick-jensen 11 months ago
    @andrewo0 - you pointed me in the right direction.
    
    It was in the subscription controller again
    	
    	$plan = Plan::where('name', '=', $request->plan)->first();
    	
    	should be 
    	
    	$plan = Plan::where('plan_id', '=', $request->plan)->first();

    @andrewo0 - you pointed me in the right direction.

    It was in the subscription controller again

    $plan = Plan::where('name', '=', $request->plan)->first();
    
    should be 
    
    $plan = Plan::where('plan_id', '=', $request->plan)->first();
    
  • rjkmelb 11 months ago
    I can't reproduce this issue, can you please explain where you are seeing this issue?
    
    

    I can't reproduce this issue, can you please explain where you are seeing this issue?

  • nick-jensen 11 months ago
    This is happening in the /settings/plans when there is already an active plan and card on file.

    This is happening in the /settings/plans when there is already an active plan and card on file.

  • andrewo0 11 months ago
    I have seen this issue when you create a subscription and then remove it out of stripe and then try to change the plan it will keep reloading.
    it has to do with the call it's doing to the provider it can't find the subscription so it gives a not find response.

    I have seen this issue when you create a subscription and then remove it out of stripe and then try to change the plan it will keep reloading. it has to do with the call it's doing to the provider it can't find the subscription so it gives a not find response.

  • nick-jensen 11 months ago
    I believe that it is not actively setting the subscription - - This reminds me of a bug that I had to fix with the plan registration in the first place. I will keep digging.

    I believe that it is not actively setting the subscription - - This reminds me of a bug that I had to fix with the plan registration in the first place. I will keep digging.

  • nick-jensen 11 months ago
    @andrewo0 - you pointed me in the right direction.
    
    It was in the subscription controller again
    	
    	$plan = Plan::where('name', '=', $request->plan)->first();
    	
    	should be 
    	
    	$plan = Plan::where('plan_id', '=', $request->plan)->first();

    @andrewo0 - you pointed me in the right direction.

    It was in the subscription controller again

    $plan = Plan::where('name', '=', $request->plan)->first();
    
    should be 
    
    $plan = Plan::where('plan_id', '=', $request->plan)->first();
    
  • andrewo0 10 months ago
    @nick-jensen 
    
    Thanks for posting your solution i think this will help other Wave Users.
    
    

    @nick-jensen

    Thanks for posting your solution i think this will help other Wave Users.

Please login or signup to leave a response.

Login

or Sign Up

Sign Up

or Login
×
Want to create your own SAAS?

I can teach you to create your own Software as a Service. Click here to learn more!

Visit SAAS Adventure!