Images not showing in view

Posted In Wave
  • sedi-bakhshi 1 year ago
    After installing laravel wave, images not showing in view but there is the path in the browser like this:
    src="http://127.0.0.1:8000//storage/themes/February2018/UUgOwPG08CnLLBOtgNWR.png".
    I will be gratefull if help me for solving this problem. 
    
    P.S: I tried to delete the storage in the public folder and run "storage:link" command but it didn't work. 

    After installing laravel wave, images not showing in view but there is the path in the browser like this: src="http://127.0.0.1:8000//storage/themes/February2018/UUgOwPG08CnLLBOtgNWR.png". I will be gratefull if help me for solving this problem.

    P.S: I tried to delete the storage in the public folder and run "storage:link" command but it didn't work.

  • guppy 1 year ago
    did you set the URL correct in your .env file? becuase you have a // after the URL. Check if you have a / too much at the ending.

    did you set the URL correct in your .env file? becuase you have a // after the URL. Check if you have a / too much at the ending.

  • sedi-bakhshi 1 year ago
    Thanks for your reply. I checked it. I didn't have any / after the URL.

    Thanks for your reply. I checked it. I didn't have any / after the URL.

  • mirene 1 year ago
    I have the same exact problem (on Win 10).  Trying to debug my storage path issue - any ideas?

    I have the same exact problem (on Win 10). Trying to debug my storage path issue - any ideas?

  • sedi-bakhshi 1 year ago
    @mirene I resolved it by editing .env file. Put APP_URL=http://127.0.0.1:8000  then run php artisan config:clear command. It will be fix after reset the terminal. 

    @mirene I resolved it by editing .env file. Put APP_URL=http://127.0.0.1:8000 then run php artisan config:clear command. It will be fix after reset the terminal.

  • jake-ocean 1 year ago
    I had the same issue, and I resolved it by deleteding the public/storage folder and then rerunning php artisan storage:link

    I had the same issue, and I resolved it by deleteding the public/storage folder and then rerunning php artisan storage:link

  • rjkmelb 1 year ago
    I had the same issue, resolved it by removing the storage directory and then clicking on Fix Storage Link inside the Voyager admin.
    
    If you look at the symlink created during installation you'll see it's  /Users/tony/Sites/wavedev/storage/app/public
    
    Removing that link and then logging into Wave, then the Voyager dashboard will provide you an option to repair the symbolic link - which fixes the issue.

    I had the same issue, resolved it by removing the storage directory and then clicking on Fix Storage Link inside the Voyager admin.

    If you look at the symlink created during installation you'll see it's /Users/tony/Sites/wavedev/storage/app/public

    Removing that link and then logging into Wave, then the Voyager dashboard will provide you an option to repair the symbolic link - which fixes the issue.

  • sedi-bakhshi 1 year ago
    Thank you for sharing your experience with us.

    Thank you for sharing your experience with us.

  • dustin 4 months ago
    Where is the Fix Storage Link located?

    Where is the Fix Storage Link located?

Please login or signup to leave a response.

Login

or Sign Up

Sign Up

or Login
×
Want to create your own SAAS?

I can teach you to create your own Software as a Service. Click here to learn more!

Visit SAAS Adventure!